$re = '/^.*?[.?!]/';
$str = 'Stack overflow is the best? I am also the best.';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;