re = /^.*?[.?!]/
str = 'Stack overflow is the best? I am also the best.'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result