import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(--.*)|(((\\/\\*)+?[\\w\\W]+?(\\*\\/)+))";
final String string = "--GO\n"
+ "--SET ANSI_NULLS ON\n"
+ "--GO\n"
+ "--SET QUOTED_IDENTIFIER ON\n"
+ "--GO\n\n"
+ "/*\n"
+ " DECLARE @Gas SMALLDATETIME = '1/1/2016',\n"
+ " @System VARCHAR(Max) = '30',--'12,76,466,465,30,226',\n"
+ " /*following param is to help decide Transportation or Storage */\n"
+ " @Contract INT = 0,--Transport or (1 = storage). \n"
+ " /*following param is to help decide dth or %*/\n"
+ " -- Contract Period 0 = 5 Years, 1 = 10 years,..., 4=25 years\n"
+ " \n"
+ "*/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}