import Foundation
let pattern = #"(--.*)|(((\/\*)+?[\w\W]+?(\*\/)+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
--GO
--SET ANSI_NULLS ON
--GO
--SET QUOTED_IDENTIFIER ON
--GO
/*
DECLARE @Gas SMALLDATETIME = '1/1/2016',
@System VARCHAR(Max) = '30',--'12,76,466,465,30,226',
/*following param is to help decide Transportation or Storage */
@Contract INT = 0,--Transport or (1 = storage).
/*following param is to help decide dth or %*/
-- Contract Period 0 = 5 Years, 1 = 10 years,..., 4=25 years
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)