use strict;
my $str = '--GO
--SET ANSI_NULLS ON
--GO
--SET QUOTED_IDENTIFIER ON
--GO
/*
DECLARE @Gas SMALLDATETIME = \'1/1/2016\',
@System VARCHAR(Max) = \'30\',--\'12,76,466,465,30,226\',
/*following param is to help decide Transportation or Storage */
@Contract INT = 0,--Transport or (1 = storage).
/*following param is to help decide dth or %*/
-- Contract Period 0 = 5 Years, 1 = 10 years,..., 4=25 years
*/';
my $regex = qr/(--.*)|(((\/\*)+?[\w\W]+?(\*\/)+))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}