#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^dog\b(?:.*\n)+?cat\n(.*(?:\n.*)*?)(?=\ndog|\Z)"
Local $sString = "dog 1" & @CRLF & _
"wuff" & @CRLF & _
"wuff" & @CRLF & _
"cat" & @CRLF & _
"123" & @CRLF & _
"XYZ" & @CRLF & _
"dog 1" & @CRLF & _
"wuff" & @CRLF & _
"wuff" & @CRLF & _
"cat" & @CRLF & _
"456" & @CRLF & _
"ABC" & @CRLF & _
"dog 1" & @CRLF & _
"wuff" & @CRLF & _
"wuff" & @CRLF & _
"cat" & @CRLF & _
"789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")