import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^dog\\b(?:.*\\n)+?cat\\n(.*(?:\\n.*)*?)(?=\\ndog|\\Z)";
final String string = "dog 1\n"
+ "wuff\n"
+ "wuff\n"
+ "cat\n"
+ "123\n"
+ "XYZ\n"
+ "dog 1\n"
+ "wuff\n"
+ "wuff\n"
+ "cat\n"
+ "456\n"
+ "ABC\n"
+ "dog 1\n"
+ "wuff\n"
+ "wuff\n"
+ "cat\n"
+ "789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}