package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bBuilding[\s:]+(\d+(?:\.\d+)?)\b`)
var str = `Building 38 House 10
Building : 10.5 house 900`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}