// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bBuilding[\s:]+(\d+(?:\.\d+)?)\b").unwrap();
let string = "Building 38 House 10
Building : 10.5 house 900";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}