import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(`{3}.*[\\n\\r][^]*?^`{3})";
final String string = "Find: `^(.*)`\n"
+ "Replace: `Prefix-\\1`\n\n"
+ "```\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "```\n\n"
+ "Into:\n\n"
+ "```\n"
+ "Prefix-1\n"
+ "Prefix-2\n"
+ "Prefix-3\n"
+ "```\n\n"
+ "Thanks. That’s handy, but I’m not likely to remember it (regex not my thing), whereas an action can be named and easily run.\n\n"
+ "I’ve been thinking about this for while. It’s similar to other Drafts actions I’ve written, so I took some of that code and built [this](https://actions.getdrafts.com/a/17N).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}