import re
regex = re.compile(r"^(`{3}.*[\n\r][^]*?^`{3})", flags=re.MULTILINE)
test_str = ("Find: `^(.*)`\n"
"Replace: `Prefix-\\1`\n\n"
"```\n"
"1\n"
"2\n"
"3\n"
"```\n\n"
"Into:\n\n"
"```\n"
"Prefix-1\n"
"Prefix-2\n"
"Prefix-3\n"
"```\n\n"
"Thanks. That’s handy, but I’m not likely to remember it (regex not my thing), whereas an action can be named and easily run.\n\n"
"I’ve been thinking about this for while. It’s similar to other Drafts actions I’ve written, so I took some of that code and built [this](https://actions.getdrafts.com/a/17N).")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")