use strict;
my $str = 'Find: `^(.*)`
Replace: `Prefix-\\1`
```
1
2
3
```
Into:
```
Prefix-1
Prefix-2
Prefix-3
```
Thanks. That’s handy, but I’m not likely to remember it (regex not my thing), whereas an action can be named and easily run.
I’ve been thinking about this for while. It’s similar to other Drafts actions I’ve written, so I took some of that code and built [this](https://actions.getdrafts.com/a/17N).';
my $regex = qr/^(`{3}.*[\n\r][^]*?^`{3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}