#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\w+\.)*\w+\.com"
Local $sString = "www.aBC.com #MATCH" & @CRLF & _
"abc.com #MATCH" & @CRLF & _
"a_bc.de8f.com #MATCH" & @CRLF & _
"a.com #MATCH" & @CRLF & _
"abc #NO MATCH" & @CRLF & _
"abc..com #NO MATCH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")