package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\w+\.)*\w+\.com`)
var str = `www.aBC.com #MATCH
abc.com #MATCH
a_bc.de8f.com #MATCH
a.com #MATCH
abc #NO MATCH
abc..com #NO MATCH`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}