re = /(?:\w+\.)*\w+\.com/m
str = 'www.aBC.com #MATCH
abc.com #MATCH
a_bc.de8f.com #MATCH
a.com #MATCH
abc #NO MATCH
abc..com #NO MATCH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end