import re
regex = re.compile(r"(E)(?=\d{4})", flags=re.MULTILINE)
test_str = ("Test String\n"
"2571130,733 5533151,436 E5015 6 16 E5015 16 \n"
"2576626,674 5531614,498 E5090 6 16 E50900 16 \n"
"2576614,102 5531577,319 E50/17 1 16 E50/17 16 \n"
"2567054,088 5538296,751 E5018 6 16 ;E5018 16 \n"
"2576606,227 5531589,142 E5070 6 16 Ei5070 16 \n"
"2584724,341 5502054,434 R7070 6 17 F7070 16 \n"
"2584735,918 5502107,131 R7014 6 17 R7014 16")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")