re = /(E)(?=\d{4})/m
str = 'Test String
2571130,733 5533151,436 E5015 6 16 E5015 16
2576626,674 5531614,498 E5090 6 16 E50900 16
2576614,102 5531577,319 E50/17 1 16 E50/17 16
2567054,088 5538296,751 E5018 6 16 ;E5018 16
2576606,227 5531589,142 E5070 6 16 Ei5070 16
2584724,341 5502054,434 R7070 6 17 F7070 16
2584735,918 5502107,131 R7014 6 17 R7014 16'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end