#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s?([^\s,]+)\s([^\s,]+)(?:,|$)"
Local $sString = " server 10.0.1.187, stratum 4, offset 0.031839, delay 0.04155" & @CRLF & _
" server 10.0.1.188, stratum 5, offset -0.000584, delay 0.04158"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")