package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s?([^\s,]+)\s([^\s,]+)(?:,|$)`)
var str = ` server 10.0.1.187, stratum 4, offset 0.031839, delay 0.04155
server 10.0.1.188, stratum 5, offset -0.000584, delay 0.04158`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}