const regex = /\s?([^\s,]+)\s([^\s,]+)(?:,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s?([^\\s,]+)\\s([^\\s,]+)(?:,|$)', 'gm')
const str = ` server 10.0.1.187, stratum 4, offset 0.031839, delay 0.04155
server 10.0.1.188, stratum 5, offset -0.000584, delay 0.04158`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}