import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d)(?=(\\d{3})+$)";
final String string = "3700000000\n\n"
+ "1000\n"
+ "10000\n"
+ "100000\n"
+ "1000000\n"
+ "10000000\n\n";
final String subst = "\\1,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}