re = /(\d)(?=(\d{3})+$)/m
str = '3700000000
1000
10000
100000
1000000
10000000
'
subst = '\\1,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result