use strict;
my $str = '3700000000
1000
10000
100000
1000000
10000000
';
my $regex = qr/(\d)(?=(\d{3})+$)/mp;
my $subst = '\\1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";