#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?D)^.*z$"
Local $sString = "quiz"
Local $sSubst = "$0zes"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)