using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*z$";
string substitution = @"$0zes";
string input = @"quiz";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}