const regex = /^.*z$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*z$', '')
const str = `quiz`;
const subst = `$0zes`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);