using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/luxury/property/.*#contact-broker-msg$";
string input = @"https://www.my-website.com/luxury/property/something#contact-broker-msg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}