$re = '~/luxury/property/.*#contact-broker-msg$~';
$str = 'https://www.my-website.com/luxury/property/something#contact-broker-msg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);