re = /\/luxury\/property\/.*#contact-broker-msg$/
str = 'https://www.my-website.com/luxury/property/something#contact-broker-msg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end