package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(~~([^~~])*~~)`)
var str = `<p><span style=\"color: #44444d; font-family: Roboto, sans-serif; font-size: 16px;\">Indian women's cricket team captain **Mithali Raj** became the all-time highest run-scorer in women's ODI __cricket__, going past ~~Charlotte~~ Edwards' tally of 5,992 runs, against Australia in the ICC Women's World Cup on Wednesday. Mithali is also the second player after Charlotte Edwards to score over 500 runs in four different calendar years in women's ODI cricket.</span></p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}