import Foundation
let pattern = #"(~~([^~~])*~~)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"<p><span style=\"color: #44444d; font-family: Roboto, sans-serif; font-size: 16px;\">Indian women's cricket team captain **Mithali Raj** became the all-time highest run-scorer in women's ODI __cricket__, going past ~~Charlotte~~ Edwards' tally of 5,992 runs, against Australia in the ICC Women's World Cup on Wednesday. Mithali is also the second player after Charlotte Edwards to score over 500 runs in four different calendar years in women's ODI cricket.</span></p>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)