use strict;
my $str = '<p><span style=\\"color: #44444d; font-family: Roboto, sans-serif; font-size: 16px;\\">Indian women\'s cricket team captain **Mithali Raj** became the all-time highest run-scorer in women\'s ODI __cricket__, going past ~~Charlotte~~ Edwards\' tally of 5,992 runs, against Australia in the ICC Women\'s World Cup on Wednesday. Mithali is also the second player after Charlotte Edwards to score over 500 runs in four different calendar years in women\'s ODI cricket.</span></p>';
my $regex = qr/(~~([^~~])*~~)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}