#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<h2><a href="(.+?)" title="(.+?)""
Local $sString = " <div class="category-title">" & @CRLF & _
" <span class="category-viewall"><a href="/предавания/сезон-2016" title="Виж всички">Виж всички ></a></span>" & @CRLF & _
" <h2><a href="/предавания/сезон-2016" title="Предавания Сезон 2016">Сезон 2016</a></h2>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" <div class="category-objects">" & @CRLF & _
" <a href="560-строеж-на-сграда-хидроизолация-на-основи-зидане-на-вътрешни-стени" class="category-object" title="Строеж на сграда - хидроизолация на основи, зидане на вътрешни стени">" & @CRLF & _
" <div class="object-thumb">" & @CRLF & _
" <div class="play-icon"></div>" & @CRLF & _
" <div class="duration-icon">22:11</div> <img src="/object_images/tvshows/thumbs/9_32_stroej_sgrada.jpg" alt="Строеж на сграда - хидроизолация на основи, зидане на вътрешни стени"/></div>" & @CRLF & _
" <div class="object-title"><h3>Строеж на сграда - хидроизолация на основи, зидане на вътрешни стени</h3></div>" & @CRLF & _
"" & @CRLF & _
" </a>" & @CRLF & _
" <a href="559-зидане-на-външни-стени-и-завършването-им-с-топлоизолационни-системи-за-клинкер-или-естествени-камъни" class="category-object" title="Зидане на външни стени и завършването им с топлоизолационни системи за клинкер или естествени камъни">" & @CRLF & _
" <div class="object-thumb">" & @CRLF & _
" <div class="play-icon"></div>" & @CRLF & _
" <div class="duration-icon">22:27</div> <img src="/object_images/tvshows/thumbs/9_31_vunshni_steni.jpg" alt="Зидане на външни стени и завършването им с топлоизолационни системи за клинкер или естествени камъни"/></div>" & @CRLF & _
" <div class="object-title"><h3>Зидане на външни стени и завършването им с топлоизолационни системи за клинкер или естествени камъни</h3></div>" & @CRLF & _
"" & @CRLF & _
" </a>" & @CRLF & _
" <a href="558-плъзгаща-врата-иновации-в-обзавеждането-на-кухнята" class="category-object" title="Плъзгаща врата, иновации в обзавеждането на кухнята">" & @CRLF & _
" <div class="object-thumb">" & @CRLF & _
" <div class="play-icon"></div>" & @CRLF & _
" <div class="duration-icon">21:57</div> <img src="/object_images/tvshows/thumbs/9_30_pluzgashta_vrata.jpg" alt="Плъзгаща врата, иновации в обзавеждането на кухнята"/></div>" & @CRLF & _
" <div class="object-title"><h3>Плъзгаща врата, иновации в обзавеждането на кухнята</h3></div>" & @CRLF & _
"" & @CRLF & _
" </a>" & @CRLF & _
" <a href="557-саморазливна-замазка-обръщане-на-прозорци-измазване-на-стена-фина-шпакловка" class="category-object" title="Саморазливна замазка, обръщане на прозорци, измазване на стена, фина шпакловка">" & @CRLF & _
" <div class="object-thumb">" & @CRLF & _
" <div class="play-icon"></div>" & @CRLF & _
" <div class="duration-icon">21:08</div> <img src="/object_images/tvshows/thumbs/9_29_samorazlivna_zamazka.jpg" alt="Саморазливна замазка, обръщане на прозорци, измазване на стена, фина шпакловка"/></div>" & @CRLF & _
" <div class="object-title"><h3>Саморазливна замазка, обръщане на прозорци, измазване на стена, фина шпакловка</h3></div>" & @CRLF & _
"" & @CRLF & _
" </a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="category-title">" & @CRLF & _
" <span class="category-viewall"><a href="/предавания/сезон-2015" title="Виж всички">Виж всички ></a></span>" & @CRLF & _
" <h2><a href="/предавания/сезон-2015" title="Предавания Сезон 2015">Сезон 2015</a></h2>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")