const regex = new RegExp('<h2><a href="(.+?)" title="(.+?)"', 'g')
const str = ` <div class="category-title">
<span class="category-viewall"><a href="/предавания/сезон-2016" title="Виж всички">Виж всички ></a></span>
<h2><a href="/предавания/сезон-2016" title="Предавания Сезон 2016">Сезон 2016</a></h2>
</div>
<div class="category-objects">
<a href="560-строеж-на-сграда-хидроизолация-на-основи-зидане-на-вътрешни-стени" class="category-object" title="Строеж на сграда - хидроизолация на основи, зидане на вътрешни стени">
<div class="object-thumb">
<div class="play-icon"></div>
<div class="duration-icon">22:11</div> <img src="/object_images/tvshows/thumbs/9_32_stroej_sgrada.jpg" alt="Строеж на сграда - хидроизолация на основи, зидане на вътрешни стени"/></div>
<div class="object-title"><h3>Строеж на сграда - хидроизолация на основи, зидане на вътрешни стени</h3></div>
</a>
<a href="559-зидане-на-външни-стени-и-завършването-им-с-топлоизолационни-системи-за-клинкер-или-естествени-камъни" class="category-object" title="Зидане на външни стени и завършването им с топлоизолационни системи за клинкер или естествени камъни">
<div class="object-thumb">
<div class="play-icon"></div>
<div class="duration-icon">22:27</div> <img src="/object_images/tvshows/thumbs/9_31_vunshni_steni.jpg" alt="Зидане на външни стени и завършването им с топлоизолационни системи за клинкер или естествени камъни"/></div>
<div class="object-title"><h3>Зидане на външни стени и завършването им с топлоизолационни системи за клинкер или естествени камъни</h3></div>
</a>
<a href="558-плъзгаща-врата-иновации-в-обзавеждането-на-кухнята" class="category-object" title="Плъзгаща врата, иновации в обзавеждането на кухнята">
<div class="object-thumb">
<div class="play-icon"></div>
<div class="duration-icon">21:57</div> <img src="/object_images/tvshows/thumbs/9_30_pluzgashta_vrata.jpg" alt="Плъзгаща врата, иновации в обзавеждането на кухнята"/></div>
<div class="object-title"><h3>Плъзгаща врата, иновации в обзавеждането на кухнята</h3></div>
</a>
<a href="557-саморазливна-замазка-обръщане-на-прозорци-измазване-на-стена-фина-шпакловка" class="category-object" title="Саморазливна замазка, обръщане на прозорци, измазване на стена, фина шпакловка">
<div class="object-thumb">
<div class="play-icon"></div>
<div class="duration-icon">21:08</div> <img src="/object_images/tvshows/thumbs/9_29_samorazlivna_zamazka.jpg" alt="Саморазливна замазка, обръщане на прозорци, измазване на стена, фина шпакловка"/></div>
<div class="object-title"><h3>Саморазливна замазка, обръщане на прозорци, измазване на стена, фина шпакловка</h3></div>
</a>
</div>
<div class="category-title">
<span class="category-viewall"><a href="/предавания/сезон-2015" title="Виж всички">Виж всички ></a></span>
<h2><a href="/предавания/сезон-2015" title="Предавания Сезон 2015">Сезон 2015</a></h2>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}