const regex = new RegExp('node:[^|]*\\|name=[^|]*', 'gm')
const str = `node:milk01-01|interface:LAN|ip_address:IP_ADDRESS|name=IP_NAME
node:milk1-01|name=milk1-01
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}