import re
regex = re.compile(r"node:[^|]*\|name=[^|]*", flags=re.MULTILINE)
test_str = ("node:milk01-01|interface:LAN|ip_address:IP_ADDRESS|name=IP_NAME\n"
"node:milk1-01|name=milk1-01\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")