re = /node:[^|]*\|name=[^|]*/m
str = 'node:milk01-01|interface:LAN|ip_address:IP_ADDRESS|name=IP_NAME
node:milk1-01|name=milk1-01
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end