# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(reg)(text\d+.*?)(regtext[A-Z]+)/$1$3$2/gs;t' <<< "text regtext1 text regtext2 text regtextA regtextZ end"