re = /(reg)(text\d+.*?)(regtext[A-Z]+)/
str = 'text regtext1 text regtext2 text regtextA regtextZ end'
subst = '$1$3$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result