$re = '/(reg)(text\d+.*?)(regtext[A-Z]+)/s';
$str = 'text regtext1 text regtext2 text regtextA regtextZ end';
$subst = "$1$3$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;