using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\r\n)+|\r+|\n+";
string substitution = @" ";
string input = @"I have sometimes
texts that I
copy and past into
my Obsidian";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}