import re
regex = re.compile(r"(\r\n)+|\r+|\n+", flags=re.MULTILINE)
test_str = ("I have sometimes\n"
"texts that I\n"
"copy and past into\n"
"my Obsidian")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)