const regex = /(\r\n)+|\r+|\n+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\r\\n)+|\\r+|\\n+', 'gm')
const str = `I have sometimes
texts that I
copy and past into
my Obsidian`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);