#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)Discussion.*?\n+([A-Za-z]+ +(?:\d{2}\/){2}\d{4}\/\d+:\d+ +[^\n]+)(.*)?ABC Company Australia \| XYZ St \| Sydney NSW 2000"
Local $sString = "some body text which I don't need " & @CRLF & _
"" & @CRLF & _
"Discussion:" & @CRLF & _
"Tue 26/04/2022/2:48 PM UTC+10/ ABC User-" & @CRLF & _
"" & @CRLF & _
"TEST description - this should be logged as a comment. --- This is the part I need" & @CRLF & _
"" & @CRLF & _
"ABC Company Australia | XYZ St | Sydney NSW 2000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")