import re
regex = re.compile(r"Discussion.*?\n+([A-Za-z]+ +(?:\d{2}\/){2}\d{4}\/\d+:\d+ +[^\n]+)(.*)?ABC Company Australia \| XYZ St \| Sydney NSW 2000", flags=re.MULTILINE | re.DOTALL)
test_str = ("some body text which I don't need \n\n"
"Discussion:\n"
"Tue 26/04/2022/2:48 PM UTC+10/ ABC User-\n\n"
"TEST description - this should be logged as a comment. --- This is the part I need\n\n"
"ABC Company Australia | XYZ St | Sydney NSW 2000\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")