$re = '/Discussion.*?\n+([A-Za-z]+ +(?:\d{2}\/){2}\d{4}\/\d+:\d+ +[^\n]+)(.*)?ABC Company Australia \| XYZ St \| Sydney NSW 2000/ms';
$str = 'some body text which I don\'t need
Discussion:
Tue 26/04/2022/2:48 PM UTC+10/ ABC User-
TEST description - this should be logged as a comment. --- This is the part I need
ABC Company Australia | XYZ St | Sydney NSW 2000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);