#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " \K&(?= .* & )"
Local $sString = "GROUP 1" & @CRLF & _
"GROUP 1 & GROUP 2" & @CRLF & _
"GROUP 1 & GROUP 2 & GROUP 3" & @CRLF & _
"GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4" & @CRLF & _
""
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)