import re
regex = re.compile(r" \K&(?= .* & )")
test_str = ("GROUP 1\n"
"GROUP 1 & GROUP 2\n"
"GROUP 1 & GROUP 2 & GROUP 3\n"
"GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4\n")
subst = ","
result = regex.sub(subst, test_str)
if result:
print(result)