const regex = /([a-z]+)(?=[^a-z\r\n]*\.[a-z]{2,6}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z]+)(?=[^a-z\\r\\n]*\\.[a-z]{2,6}$)', 'gm')
const str = `http://www.mywebsiteameW1234.com
https://www.mywebsiteameW1234.com
http://mywebsiteameW1234.com
https://mywebsiteameW1234.com`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);