package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(@\w+?)#(\d+)`)
var str = `Привет @Albamarvel#115! Как дела? Забань плиз @durov#322 пока не поздно`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}